gaaamiiのブログ

悪気なく間違ったことを書いている時があります。コメントやTwitter、ブコメなどでご指摘ください

代入演算子をちゃんと使えてなかった

Xcodeで簡単なアプリ作ったよー(はじめてのXcodeでカウンターアプリを作成)って記事を書いたけど、ソース見てたらまたしても初歩的な問題が見つかった。

「ボタン押したらカウンターの数字を+1しなさい」
っていう命令を書く時、こんな風に書いてた。

counter = counter + 1;

いや、動くけど。

そうじゃなくて、こう書けよって話。

counter += 1;


(2013/02/11) 追記:+1していくのであればこっちでした。

counter++;

インクリメント演算子ってやつですね。