gaaamiiのブログ

悪気なく間違ったことを書いている時があります。コメントやTwitter、ブコメなどでご指摘ください

なんかエラー出ると思ったらあるモジュールのバージョン上がってた

あるモジュールが1.1.1 -> 1.3.0 にあがってて、手元で新たにnpm installしたタイミングで import できなくなっていた。つらい。

解決策

npm install --save --save-exact

とやればバージョン固定できるらしい。

今どきは yarn 使った方がいいんだろうか。あまり調べられてないけど、しばらくしたらyarn使うことになりそう。